22 lines
1.0 KiB
Bash
22 lines
1.0 KiB
Bash
# Maintainer: Catriel Müller <catriel at gmail dot com>
|
|
# Maintainer: Xiufeng Guo <i@m.ac>
|
|
pkgname=synergy1-bin
|
|
pkgver=1.14.6
|
|
pkgrel=2
|
|
pkgdesc="Keyboard and mouse sharing solution. Synergy allows you to share one mouse and keyboard between multiple computers. Work seamlessly across Windows, macOS and Linux."
|
|
arch=('x86_64')
|
|
url="https://symless.com/synergy"
|
|
license=('unknown')
|
|
depends=('avahi>=0.6.16' 'gcc-libs>=5.2' 'glibc>=2.14' 'hicolor-icon-theme' 'libx11>=1.2.99.901' 'libxext' 'libxi>=1.2.99.4' 'libxtst' 'openssl-1.1>=1.1.0' 'qt5-base>=5.12.2')
|
|
conflicts=('synergy')
|
|
options=('!strip' '!emptydirs')
|
|
install=${pkgname}.install
|
|
source_x86_64=("https://storage.m.ac/linux/bin/synergy_1.14.6-stable.455c59b4_debian11_amd64.deb")
|
|
sha512sums_x86_64=('4fc400e3cd35ca5ccee7fd3695ca07d4e1b01481fd741243a7c52504897fcabd9f58eb92bcd93c49ac8cd474ccfcdf657acb59271b789ef96d26799b150f7aa0')
|
|
|
|
package(){
|
|
# Extract package data
|
|
tar xf data.tar.xz -C "${pkgdir}"
|
|
install -D -m644 "${pkgdir}/usr/share/doc/synergy/copyright" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
|
|
}
|